ssh options freeze bash

ble version: 0.4.0-devel3+0506df2 Bash version: 5.1.4(1)-release, x86_64-pc-linux-gnu

Completely freeze when add some ssh options:

ssh -v # everything stop

Into tmux nothing is displayed. into alacritty i can show this

rlanore@px-rla:[~] on ☁️  (us-east-1) ✦1
[] 🠶 ssh -vble/contrib/fzf: failed to find "fzf" base directory

This appear only on ssh command

About this issue

  • Original URL
  • State: closed
  • Created 3 years ago
  • Comments: 30 (13 by maintainers)

Most upvoted comments

I think that i found my problem with ssh. I have define an alias for ssh like

alias ssh="TERM=xterm ssh"

when disable it’ works

but i have need this because my workstation is not on xterm but a lot of server will.

also when searching to debug with strace i see that they are a lot of cache with empty file.

I make a mistake:

when i have disabled fzf i will just reload bash and the probem persist. But into a completely new shell they are no problem with ssh and without fzf.

Hi, sorry for late response i have been too busy. But now it’s ok. I did a try without fzf and the problem still append. In an ohter shell i have checked for a man -w process and it appear and disappear a lot.


ble version: 0.4.0-devel3+0506df2 Bash version: 5.0.18(1)-release (x86_64-pc-linux-gnu)

ssh -v works fine but the same “freeze” issue happened to me typing: ➤ netstat -p or ➤ netstat -a and not if I type: netstat --all

I tried before to downgrade to v0.3.3 and everything works fine, so re-tried the latest version and … I was surprised that the issue is gone ¯\(ツ)

PS: during the freeze, I found in other shell some “man -w netstat” child processes in loop…

OK, thank you for the version information! I meant 0.3.* by ble-0.3, but I just wanted to confirm which specific version of 0.3.* you have tried.

Oh, sorry. I just noticed that you have already included the result of $BLE_VERSION in the first reply. It’s just my oversight. Thank you