share-note: Large notes fail to share

Sharing a note, I get “Unable to find the file to update, please delete any existing share links and try again”, or a 403 response. I used to use the old version of the plugin through templater, so I thought it might be due to the old share links, but removing them did not help.

That means it’s probably an authentication issue. My user ID is efc89ed13177ef9c8c77729abc03b3cc.

Fix for “Unable to find the file to update”: go to this comment. “Large notes fail” starts after that.

About this issue

  • Original URL
  • State: closed
  • Created 10 months ago
  • Comments: 16 (16 by maintainers)

Commits related to this issue

Most upvoted comments

@TheColorman MathJax / LaTeX support is now added in 0.3.2.

You will likely need to Force re-upload one of your notes which includes MathJax to get it to start working, as this will inject the needed styles into your public CSS and purge the cache. Once you’ve done that the rest of your notes should start working without issues.

Here’s your example note

@TheColorman the long note encryption is fixed in 0.2.6.

For your math-heavy note, the method I’m using to get the HTML data from Obsidian seems to have intermittent failures where the note data provided to my plugin is truncated before the end of the note.

I think I will need to page through each of the Obsidian viewport views and piece them together that way. I will leave this ticket open.

Thanks for sharing that - I can replicate the issue so I will debug and solve. Looks like it might be related to the size of the note itself. I can cause the same failure with 20,000 words of Lorem Ipsum.

No idea regarding the A/B failures 😬 If it does reoccur, we might be able to diagnose now.

Ok now this is really weird. I have my main vault, Main. I created vault A, and copied .obsidian from Main to A. Upload did not work. I uninstalled and reinstalled the plugin in A. Upload did not work. I then created a new vault B, installed the plugin (this time without copying my .obsidian) and sharing worked. I copied the plugin folder to vault A, sharing worked.

Then I copied it to vault Main, did not work. Then I re-created vault B and copied from B to Main and it still did not work.

Sorry, looks like I might be needing the debugger after all unless I figure out what happened😅