node-pixel: NoWritablePortError

I’m using johnny-five and node-pixel. I’ve used interchange to flash the arduino. I used the johnny-five instantiation snippet to get started. I’m using an 8 led neopixel stick on pin 6. When I run the script, I get the following error NoWritablePortError: Node Pixel FIRMATA controller requires IO that can write out

I’m using a kuman uno r3.

About this issue

  • Original URL
  • State: closed
  • Created 5 years ago
  • Comments: 33 (9 by maintainers)

Most upvoted comments

Any news about merging this fix?

Just installed using git+ branch and it worked :shipit:

Thanks for that - I have been away for the last few weeks so will need to take a look at this. Given firmata has had a major version change I expect this will definitely break some behaviour. It might take a little while to get through what is going on but will attempt that over the next week. If you have some time for some testing that would be greatly appreciated as well.

In the meantime, as a note if anyone sees this - please npm install firmata@1.0.0 and then install everything else and it should continue to work.

– Andrew Fisher

On Sun, Jun 2, 2019 at 6:59 AM Joshua Richards wrote:

Works! Did the same thing.

— You are receiving this because you are subscribed to this thread. Reply to this email directly, view it on GitHub, or mute the thread .

Yes. I used the example ‘Firmata instantiation’ and not the johnny-five example. Then I installed expicit the version 1.0.0 of firmata: npm install firmata@1.0.0. Without the version you get version 2.0.0. johnny-five is also using firmata 2.0.0. It seems that something changed in 2.0.0 and node-pixel doesn’t know that.

Okay so I’ve patched interchange so installing against the branch as given above should now work again. If peeps can test this then that would be great. Outside of that, I’ll retest this whole branch over the weekend and then merge it in if it’s good.

Hey, @ajfisher. Looks like it works well. Maybe it’s time to merge it 😃


Works! Did the same thing.

Seems to be a problem with firmata@2.0.0. With firmata@1.0.0 it works