WLED: WLED-AP never appears

  • esp32s
  • binaries tried: 0.8.5, 0.8.6, 0.9.0-b1

No matter what I do, the wireless access point never shows up. The logs from esphomeflasher are completely blank, as if the device never actually starts up.

Logs via esptool.py

$ esptool.py write_flash 0x10000 ~/Downloads/WLED_0.8.5_ESP32.bin
esptool.py v2.8
Found 4 serial ports
Serial port /dev/cu.usbserial-A900HH38
Detecting chip type... ESP32
Chip is ESP32D0WDQ6 (revision 1)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
Crystal is 40MHz
MAC: 3c:71:bf:f9:fb:48
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Auto-detected Flash size: 4MB
Compressed 1027744 bytes to 593610...
Wrote 1027744 bytes (593610 compressed) at 0x00010000 in 52.7 seconds (effective 156.0 kbit/s)...
Hash of data verified.

Hard resetting via RTS pin...

Logs via esphomeflasher

Using '/dev/cu.usbserial-A900HH38' as serial port.
Detecting chip type... ESP32

Chip Info:
 - Chip Family: ESP32
 - Chip Model: ESP32D0WDQ6 (revision 1)
 - Number of Cores: 2
 - Max CPU Frequency: 240MHz
 - Has Bluetooth: YES
 - Has Embedded Flash: NO
 - Has Factory-Calibrated ADC: YES
 - MAC Address: 3C:71:BF:F9:FB:48
Uploading stub...
Running stub...
Stub running...
Changing baud rate to 460800
 - Flash Size: 4MB
 - Flash Mode: dio
 - Flash Frequency: 80MHz
Erasing flash (this may take a while)...
Chip erase completed successfully in 6.6s
Compressed 15856 bytes to 10276...
Writing at 0x00001000... (100 %)Wrote 15856 bytes (10276 compressed) at 0x00001000 in 0.2 seconds (effective 531.9 kbit/s)...
Hash of data verified.
Compressed 3072 bytes to 143...
Writing at 0x00008000... (100 %)Wrote 3072 bytes (143 compressed) at 0x00008000 in 0.0 seconds (effective 1330.0 kbit/s)...
Hash of data verified.
Compressed 8192 bytes to 47...
Writing at 0x0000e000... (100 %)Wrote 8192 bytes (47 compressed) at 0x0000e000 in 0.0 seconds (effective 3957.8 kbit/s)...
Hash of data verified.
Compressed 1034832 bytes to 591312...
Writing at 0x000a0000... (100 %)Wrote 1034832 bytes (591312 compressed) at 0x00010000 in 14.3 seconds (effective 578.9 kbit/s)...
Hash of data verified.

Hard Resetting...
Done! Flashing is complete!

Showing logs:

NOTE: The line from the wiki is very vague for someone unfamiliar with arduino

ESP32 (you will need to have a bootloader installed, you can flash the Arduino blink example to do that)

I believe I flashed the device with the “blink” example (though the blink example apparently is not ready out of the box and took some googling to figure out you need to add something like #define LED_BUILTIN 13 to the file before installing). I did this, it installed, then I went back and tried to install WLED again, same results.

Is there something wrong with what I’m doing? Is a step missing from the instructions?

About this issue

  • Original URL
  • State: closed
  • Created 5 years ago
  • Comments: 17 (3 by maintainers)

Most upvoted comments

Hi, sorry for the trouble getting it to work. I realized that even flashing the blink sketch requires you to install the ESP32 arduino core, which is not hard, but also not trivial. I’ve extracted the Arduino bootloader to a .bin file for you: https://drive.google.com/file/d/1NQrBwb5WJz6WSEbotW-6NrmiLJ6Hc04F/view?usp=sharing

Just flash it to your ESP32 using

esptool.py write_flash 0x0 .\esp32_bootloader.bin

and everything should work! (if it doesn’t, try running the regular ESP32 flash command from quickstart again)

I switched to a D1 mini using 0.9.x and it’s working