ag-grid: from 27.0.0 to 27.0.1: Sass error: The 'min' sass function clashes with the css 'min' function

Since 27.0.1 At this position in the base-theme, the usage of the ‘min’ function is problematic when sass compiles:

ModuleBuildError: Module build failed (from ./node_modules/sass-loader/dist/cjs.js): SassError: var(--ag-theme-row-height, 26px) is not a number. From this line in your repository :

About this issue

  • Original URL
  • State: closed
  • Created 2 years ago
  • Reactions: 6
  • Comments: 19 (3 by maintainers)

Most upvoted comments

@makinggoodsoftware I am unable to search for AG-6417 in or I can find AG-6416 and many other issues. How to find AG-6417 in either lists?

@kiril-matev I cannot confirm this unfortunately, or maybe I am doing something wrong?


  "dependencies": {
    "@ag-grid-enterprise/all-modules": "^27.1.0"


import '@ag-grid-enterprise/all-modules/dist/styles/ag-grid.css';
import '@ag-grid-enterprise/all-modules/dist/styles/ag-theme-alpine.css';

error: SassError: "var(--ag-row-height, 40px)" is not a number for 'min'


I made sure to check the package.json included in ag-grid and its correctly using version 27.1


Possibly important info: We have an enterprise licence, and I cannot reproduce the issue with community. Is it maybe fixed in community but not enterprise?

Using React and AG Grid 27.1 here and had the same issue. I was running "node-sass": "4.14.1" and "sass-loader": "8.0.2", and was able to get a workaround for the issue by swapping out node-sass for dart sass ("sass": "1.49.9" and "sass-loader": "10.2.1")

Hello @mleimer,

Thanks for reaching out.

I can confirm that AG-6417 was fixed as part of AG Grid 27.1.

Thank you for noting that AG-6417 wasn’t visible in the changelog. This is because of incorrect labelling, which we have now corrected.

It should be visible in changelog soon with this URL:

In any case, please upgrade to AG Grid 27.1 to resolve this.

Thank you for your time!

Here is repo for the latest version of Angular 12:

  • download / clone
  • npm install
  • npm start
  • 💥 SCSS compile error

Tried the same with the latest version of Angular 13, that didn’t give me any issues. Unfortunately for the project in question we cannot yet upgrade to Angular 13.


Your ticket has been flagged as in_zendesk, it means that we recognize this as an issue worth investigating so we have moved it to our official support channel for customers (zendesk)

We will carry on there with the investigation and we will update you as soon as possible.


Also getting the same error when upgrading to 27.0.1. This error can easily be reproduced as following:

@import 'ag-grid-community/dist/styles/ag-grid.scss';
@import 'ag-grid-community/dist/styles/ag-theme-alpine/sass/_ag-theme-alpine-mixin.scss';

.ag-theme-custom {
  @include ag-theme-alpine();

This was tested using the Angular CLI (v12.2.3)