react-native: Xcode 10: third-party: 'config.h' file not found

After upgrading from 0.44.3 -> 0.45.0, XCode no longer builds for me with the following error:

Lexical or Preprocessor Issue
'config.h' file not found

screen shot 2017-06-08 at 2 14 56 am

I am not using cocoa pods, just npm packages. Seems like some related changes have been made that may be causing this issue?

About this issue

  • Original URL
  • State: closed
  • Created 7 years ago
  • Reactions: 226
  • Comments: 134 (26 by maintainers)

Commits related to this issue

Most upvoted comments

Running into the same issue here after upgrading from 0.44. None of the above solutions or clearing caches did the trick for me. Here’s what I did to get things working again:

  • In the Terminal, navigate to the react-native/third-party/glog folder inside node_modules (for me, this was cd node_modules/react-native/third-party/glog-0.3.4)
  • Once actively in this folder, run ../../scripts/
  • Glog is configured and the required config.h header file is created for Xcode to find

Can you try removing the third-party folder in your node_modules/react-native folder?

I also have the same issue after updating from 0.44.0 > 0.45.1:

$ rm -rf node_modules/ && yarn cache clean && yarn install $ ls node_modules/react-native/ (missing third-party directory)

Xcode build fails: 'config.h' file not found

$ node_modules/react-native/ or node_modules/react-native/scripts/ $ ls node_modules/react-native/ (third-party directory found)

Xcode build succeeds.

Edit: After running once I can repeat $ rm -rf node_modules/ && yarn cache clean && yarn install after which the third-party is still missing, however a following Xcode build now correctly creates the third-party by itself and the builds succeeds.

you can just install glog yourself to solve this program. cd /glog then ./configure make
make install

build in Xcode again, problem never comes back .

For me:

  • deleting the node_modules
  • npm cache verify (Because I’m using npm version 5.0.3)
  • npm install
  • Xcode Clean
  • Xcode Run

did the trick!

I have been through this issue on RN 0.54.0 . While building iOS app with XCode 9.0.

To resolve this goto

cd /node_modules/react-native/third-party/glog-0.3.4

and run


after finishing this command Try to clean & build XCode project.

This will resolve issue.

cd node_modules/react-native/third-party/glog-*

Part of @fedeojeda95’s solution worked for me! 😃

Note that previous to achieve it I’ve upgraded react-native to version 0.50.3:


and I also did run:

rm -rf ~/.rncache


npm install

I don´t know if any of those previous steps have had any impact on next steps working on. So I’ve gone through the following steps with success:

  1. Close Xcode.

  2. Open Terminal, go to your project’s root folder and do:

    cd node_modules/react-native/third-party/glog-0.3.4/

  3. Run the configure script:


  4. Open Xcode and try to run your app.

    If on project navigator you can see the “Libraries/React.xcodeproj/ThirdParty/glog/config.h” file(not in red), that’s a good indication that your app should now compile and run ok.

I tried all the stuffs above, to no avail.


I updated npm and all that shit worked!

Same issue with RN 0.46

every time i rebuild my react-native projects… they introduce new bugs… this is ridiculous.

slow hand clap fb

For everyone else getting the error when building for devices in Xcode 10:

No member named ‘__rip’ in ‘__darwin_arm_thread_state64’

Do not use ./configure to build glog. That will produce a broken config.h in Xcode 10. Use this instead: cd node_modules/react-native/third-party/glog-0.3.5/ && ../../scripts/

Note that the version in the path might differ per react-native version…

Thank you everyone, I solved my problem.

i am
macOS 10.13.6 “react-native”: “0.56.1”

Share the steps I solved:

  1. rm -rf node_modules/ && yarn cache clean && yarn install and rm -rf ~/.rncache
  2. cd node_modules/react-native/scripts
  3. ./ If your network is slow, you can download the packages separately and move them to the rncache folder 1. folly-2016.10.31.00 2. double-conversion-1.1.5 3. glog-0.3.4 4. boost_1_63_0
  4. cd <Your-Project-Folder>/node_modules/react-native/third-party/glog-0.3.4
  5. ./configure
  6. Xcode Clean & Build

hope to help friends who have the same problem.

To resolve this error, follow below steps:


  1. Go to Project -> node_modules -> react_native
  2. Remove third-party folder
  3. Add which is given in below link:

Removing the third party folder did the trick. (I left the third-party-podspecs folder, though). Do you still want me to try the other fix?

I’ve got the same issue. 😦

this should solve:

rm -rf ~/.rncache
rm -rf node_modules
react-native run-ios

we can close this, it is not happening in latest react-native versions

I got it fixed by following this steps:

  1. Close Xcode.
  2. cd <Project-Folder>/node_modules/react-native/third-party/glog-0.3.4
  3. Run ./configure
  4. Run make
  5. Run make install
  6. Open Xcode and try building the Project.

Hope this solves the issue

rm ~/.rncache/*

and build again.

It work for me.

@damirjs just follow @doyouno 's solution

you can just install glog yourself to solve this program. cd /glog then ./configure make make install

build in Xcode again, problem never comes back .

I think we’ve got to work on a less entitled attitude. It’s easy to forget that we’re using React-Native, and the work of others, for free.

Sure, it’s frustrating to have build issues, but come up with a procedure to test the build before you use it? You don’t need to follow bleeding edge.

0.46.3 is out with this fix.

This issue is not resolved. I get seemingly random occurances on package updates.

The original issue appears to be solved. To minimize confusion, please open a new issue with information pertaining to your particular situation.

just use previous version 0.44 react-native init --version=“0.44.0” YourAPP till the issue resolved By R-N team 👍 1

what worked for me:

yarn cache clean rm -rf node_modules yarn install

In my case after running ../../scripts/ I always got an error like this:

configure: error: in 'PATH_TO_RN_PROJECT/node_modules/react-native/third-party/glog-0.3.4':
configure: error: C compiler cannot create executables

In config.log I found the following line:

checking for arm-apple-darwin-gcc... /Users/MYUSER/Downloads/Xcode -arch armv7 -isysroot /Users/MYUSER/Downloads/Xcode

After moving my xcode to programs and rename it from ‘Xcode 9’ to ‘Xcode’ the error was gone.

I’m posting this because maybe someone has a similar situation 🍺


SCRIPTDIR=$(cd "$(dirname "$0")"; pwd)
# SCRIPTDIR="../../scripts"

It works.

@tonypee chill out my dude…

yea they introduce bugs, yea they could use some more testing before release, but they are working hard. no need to go full mock-mode with a slow hand clap. its not just you having these problems. complaining is cool. whining is not.

Not to sound critical, but this is such a critical issue. How could this have gotten out? Makes me worry.

This is not a problem only for upgrades. I get the same error even on new RN 0.46 projects.

Looks like there’s a bug with the install-third-party scripts. In can you replace “$SCRIPTDIR/” with “…/…/scripts/”?

for anyone finding this on RN v0.47.2, I needed to follow this very specific order of steps to get it working:

  1. rm -rf node_modules && npm install
  2. open the project in Xcode, clean, and try to build. It will fail with an error saying something about “exit code 77” when building double-conversion
  3. Now go into node_modules/react-native/third-party/glog and run ../../scripts/
  4. rm -rf ~/.rncache
  5. Clean and build again in Xcode

For whatever reason, other combinations of the other solutions wouldn’t work. Like running separately (with the $SOURCEDIR fix) before ../../scripts/ would still get the error.

Fixed using earlier versions. Try this

react-native init --version=“0.42.0” AwesomeProject

Same issue as @mattijsf, upgrade to Xcode 10 GM and a yarn install caused this and #16106 for some reason

cd /glog then
make install

make install still error but it’s build succeeded. Version on my machine:

react-native-cli: 2.0.1
react-native: 0.51.0

I was still having this problem using the latest release, react-native 0.50.3.

After running all the build scripts manually one by one (and almost giving up in the process, btw), I found that moving into glog folder (node_modules/react-native/third-party/glog-0.3.4/) and running the build process actually fixed it. The commands used where the following:

  • ./configure
  • make
  • make install

After all of this, voila, it was working!

Nevertheless, after running the last command, I saw a message indicating that it could not find /Applications/, which seemed really weird.

I realized that since I was using different versions of Xcode at the same time (8.3.2 and 9.0) I renamed both applications to indicate their version (Xcode 8.3.2 and Xcode 9, respectively). Just renaming the latest one to Xcode again, and running rm -rf ~/.rncache fixed it!

Seems to me that this could be easy fixable, since it looks like the path is harcoded. Just check that that Xcode was renamed correctly. Weirdly, I had to restart my computer in order for macOS to apply the name change

Running the following script on npm post install seems to have fixed my CI problems:

# set CUR_SPACE below before executing this script
#CUR_SPACE is just my react-native project directory, set it to whatever yours is

CUR_SPACE=<your react-native project directory>

cd $CUR_SPACE/node_modules/react-native/scripts/
curl >
chmod +x
printf "\nManually upgraded the script.\n"

This is a returning issue every now an then. This time I got it after upgrading to Xcode 10. The steps from @lyon007 worked for me.

React Native Version: 0.54.2 One step: @fedeojeda95

cd node_modules/react-native/third-party/glog-0.3.4
make install

Two step: @Ignigena

cd node_modules/react-native/scripts


I’m installed Xcode (9.3) and Xcode 9.2. I use Xcode 9.2 to build. Because 9.3 has a problem with RN compatibility. Thank you for the above two. I hope my situation is of reference to you.

Just hit this after updating from React Native v0.47 to v0.50

I hit Product > Clean, closed Xcode, combined the instructions above:

rm -rf ~/.rncache
rm -rf node_modules
npm install

Then reopened Xcode, and the build worked normally! 👍

  1. Delete third-party in react-native directory
  2. Check files in ~/.rncache. In this directory, there are 4 file boost_1_63_0.tar.gz double-conversion-1.1.5.tar.gz folly-2016.09.26.00.tar.gz and glog-0.3.4.tar.gz.Make sure all of this file is ok.If any problem, you can download and replace by youself.
  3. Open xcode clean and build.

My problem is, when downloading boost_1_63_0.tar.gz , it failed.

I got the same issue on 0.46.4 version and on 0.47.0-rc.4. What I’m doing wrong?

My above comment about files that are not linked correctly solved by itself so I don’t think the errors were related to that at all:

  1. $ rm -rf node_modules/ && yarn cache clean && yarn install
  2. $ open node_modules/react-native/React/React.xcodeproj/
  3. Observe path of node_modules/react-native/React/glog-0.3.4/src/demangle.h: wrong & missing
  4. Build the project (succeeds)
  5. Observe path of node_modules/react-native/React/glog-0.3.4/src/demangle.h: still wrong & missing
  6. Quit Xcode
  7. $ open node_modules/react-native/React/React.xcodeproj/
  8. Observe path of node_modules/react-native/third-party/glog-0.3.4/src/config.h: corrected with /third-party & exists.

Basically the paths were changed / fixed after a successful build of the React project. Xcode just didn’t refresh the paths correctly.

I still get the same folly::detail::formatBinary related errors as @dioxide

thank you! @Ignigena your solution still works for 0.55.2.


Environment: OS: macOS High Sierra 10.13.6 Node: 10.10.0 Yarn: 1.9.4 npm: 6.4.1 Watchman: 4.9.0 Xcode: Xcode 10.0 Build version 10A255 Android Studio: 3.1 AI-173.4819257

Packages: (wanted => installed) react: 16.3.2 => 16.3.2 react-native: 0.55.2 => 0.55.2

I just ran in this on 0.51. I went to the third-party folder and deleted it. After that started the build process in iOS and it recreated the folder and all went good.

Yup, after rm -rf node_modules && npm i it worked. Thanks guys.

@ddpatel2606 Thank you for answer! make install threw this error:

make: /Volumes/Macintosh: No such file or directory
make: *** [install-am] Error 1

and packager:

Error watching file for changes: EMFILE
{"code":"EMFILE","errno":"EMFILE","syscall":"Error watching file for changes:","filename":null}
Error: Error watching file for changes: EMFILE
    at exports._errnoException (util.js:1018:11)
    at FSEvent.FSWatcher._handle.onchange (fs.js:1420:11)

but app build successfully.

UPD: For resolving problems with watcher i used this recommendations: and Its works!!!

Running into the same issue here after upgrading from 0.44. None of the above solutions or clearing caches did the trick for me. Here’s what I did to get things working again:

  • In the Terminal, navigate to the react-native/third-party/glog folder inside node_modules (for me, this was cd node_modules/react-native/third-party/glog-0.3.4)
  • Once actively in this folder, run ../../scripts/
  • Glog is configured and the required config.h header file is created for Xcode to find

I tried the above code, then I got the following error like configure: error: in /Users/macmini1/Downloads/react-native-youtube-master/example/node_modules/react-native/third-party/glog-0.3.4': configure: error: C compiler cannot create executables See config.log’ for more details

I solved by using the following command

$ ./configure --host arm-apple-darwin

I have worked npm cache clean --force many times. I have worked npm install many times. But I do not have glog folder.

react-native: 0.54.3

My Podfile:

platform :ios, '8.0'

target 'appName' do
  # Uncomment the next line if you're using Swift or would like to use dynamic frameworks
  # use_frameworks!

  # Pods for appName

  # Your 'node_modules' directory is probably in the root of your project,
  # but if not, adjust the `:path` accordingly
  pod 'React', :path => '../node_modules/react-native', :subspecs => [
    'CxxBridge', # Include this for RN >= 0.47
    'DevSupport', # Include this to enable In-App Devmenu if RN >= 0.43
    'RCTWebSocket', # needed for debugging
    # Add any other subspecs you want to use in your project
  # Explicitly include Yoga if you are using RN >= 0.42.0
  pod 'yoga', :path => '../node_modules/react-native/ReactCommon/yoga'

  # Third party deps podspec link
  pod 'DoubleConversion', :podspec => '../node_modules/react-native/third-party-podspecs/DoubleConversion.podspec'
  pod 'GLog', :podspec => '../node_modules/react-native/third-party-podspecs/GLog.podspec'
  pod 'Folly', :podspec => '../node_modules/react-native/third-party-podspecs/Folly.podspec'


After pod install [!] The name of the given podspec `glog` doesn't match the expected one `GLog`

I do not have glog folder in /node_modules/react-native: ekran resmi 2018-03-29 15 17 59

@vishaalkolhe90 Thanks, you’re my time saver. (RN 0.52.0, XCode 9.2)

Hi all, I am getting following error on running ./configure

checking for a BSD-compatible install… /usr/bin/install -c checking whether build environment is sane… configure: error: unsafe absolute working directory name

Hi everyone … i have bug ‘config.h’ file not found but i run ../../scripts/ it didn’t work and in teminal show Vuongs-MacBook-Pro:glog-0.3.4 vuonghaithanh$ ../../scripts/ ../../scripts/ line 7: xcrun: command not found ../../scripts/ line 7: xcrun: command not found checking for a BSD-compatible install... /usr/local/bin/ginstall -c checking whether build environment is sane... yes /Users/vuonghaithanh/WebstormProjects/testreact/node_modules/react-native/third-party/glog-0.3.4/missing: Unknown –is-lightweight’ option Try /Users/vuonghaithanh/WebstormProjects/testreact/node_modules/react-native/third-party/glog-0.3.4/missing --help' for more information configure: WARNING: 'missing' script is too old or missing checking for arm-apple-darwin-strip... no checking for strip... strip checking for a thread-safe mkdir -p... /usr/local/bin/gmkdir -p checking for gawk... no checking for mawk... no checking for nawk... no checking for awk... awk checking whether make sets $(MAKE)... yes checking whether make supports nested variables... yes checking for arm-apple-darwin-gcc... -arch armv7 -isysroot checking whether the C compiler works... no configure: error: in /Users/vuonghaithanh/WebstormProjects/testreact/node_modules/react-native/third-party/glog-0.3.4’: configure: error: C compiler cannot create executables See config.log' for more details

pls help me how to fix

react-native-cli: 2.0.1 react-native: 0.53.3

Btw, removing the node_modules directory from the project and running “npm install” fixed the problem somehow.

@sibelius That procedure did not fix it on my machine. Still happening with rn 0.53 for me on a brand new project, initialised just for testing this.

Even went so far as deinstalling Xcode and nvm and upgraded to node 9.4.0.

As said I had to fall back to rn 0.39 in order to successfully build.

RN v. 0.50.4. Had the same issue. Did 2 and 3 from @RicardoBarroso comment and also cleared the project -> worked.

*The only thing was that after this I had to completely delete an app from a device, cuz a default iOS launch screen (xib) started to appea and I was unable to remove it (there was no xib in the xcodeproj).

Well, for me, nothing of this worked, the third-party folder doesn’t even exist anymore in 0.48.3

I manually added the config.h file to the Pods project and pointed it to the GLog target as public for fixing the issue, seems like the prepare_command (in the podspec) is never executed when using the :path option in the Podfile so is never executed, also configure is missing (which is needed in the script)


I have another 2 test projects that I haven’t been able to build, and I spent about 3 days finding versions for this one which would build, just to leave it for 2 weeks, now done a fresh install to find this bug. I’m locked on 0.45, so not sure how it worked previously and not now. I thought I’d locked versions so that I wouldn’t have this.

It’s just really testing my faith in the platform, as I’d love to be able to rely on it, but I’m spending the majority of my time with compile errors

Anyways, thanks

On Tue, Jul 18, 2017 at 6:05 PM Pavlos Vinieratos wrote:

@tonypee chill out my dude…

yea they introduce bugs, yea they could use some more testing before release #14864, but they are working hard. no need to go full mock-mode with a slow hand clap. its not just you having these problems. complaining is cool. whining is not.

— You are receiving this because you were mentioned. Reply to this email directly, view it on GitHub, or mute the thread .

– Tony Polinelli

i followed your tips

cd /node_modules/react-native/scripts/ curl > chmod +x

i get this error now

/Users/Alain/Library/Developer/Xcode/DerivedData/iosReactTest2-bphijysweorcfectrxtfnflaibcn/Build/Intermediates/ line 3: …/node_modules/react-native/packager/ No such file or directory

+1 , this is a critical issue! since 0.45

I have seen that too. I am very surprised this got released with this very critical issue.

Get Outlook for iOS

From: Gary F Sent: Tuesday, July 11, 2017 6:11:47 PM To: facebook/react-native Cc: Ujwal Setlur; Comment Subject: Re: [facebook/react-native] [0.45.0] third-party: ‘config.h’ file not found (#14382)

@Ignigena’s work around fixes it for me too. But I’ve seen 2 XCode build errors, somewhat alternating when I was moving files and around and trying to find a fix with yarn cache clean and such. One being the one this issue originally posted about missing config.h, the other to do with double-conversion.

XCode output below on Shell Script Invocation Error in double-conversion:

PhaseScriptExecution Install\ Third\ Party /Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ cd /Users/<user>/Documents/code/<project>/node_modules/react-native/React export ACTION=build export AD_HOC_CODE_SIGNING_ALLOWED=NO export ALTERNATE_GROUP=staff export ALTERNATE_MODE=u+w,go-w,a+rX export ALTERNATE_OWNER=gary export ALWAYS_EMBED_SWIFT_STANDARD_LIBRARIES=NO export ALWAYS_SEARCH_USER_PATHS=NO export ALWAYS_USE_SEPARATE_HEADERMAPS=NO export APPLE_INTERNAL_DEVELOPER_DIR=/AppleInternal/Developer export APPLE_INTERNAL_DIR=/AppleInternal export APPLE_INTERNAL_DOCUMENTATION_DIR=/AppleInternal/Documentation export APPLE_INTERNAL_LIBRARY_DIR=/AppleInternal/Library export APPLE_INTERNAL_TOOLS=/AppleInternal/Developer/Tools export APPLICATION_EXTENSION_API_ONLY=NO export APPLY_RULES_IN_COPY_FILES=NO export ARCHS=“armv7 arm64” export ARCHS_STANDARD=“armv7 arm64” export ARCHS_STANDARD_32_64_BIT=“armv7 arm64” export ARCHS_STANDARD_32_BIT=armv7 export ARCHS_STANDARD_64_BIT=arm64 export ARCHS_STANDARD_INCLUDING_64_BIT=“armv7 arm64” export ARCHS_UNIVERSAL_IPHONE_OS=“armv7 arm64” export AVAILABLE_PLATFORMS=“appletvos appletvsimulator iphoneos iphonesimulator macosx watchos watchsimulator” export BITCODE_GENERATION_MODE=marker export BUILD_ACTIVE_RESOURCES_ONLY=YES export BUILD_COMPONENTS=“headers build” export BUILD_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products export BUILD_ROOT=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products export BUILD_STYLE= export BUILD_VARIANTS=normal export BUILT_PRODUCTS_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products/Release-iphoneos export CACHE_ROOT=/var/folders/q2/nn87n125621g5t3h_n_nx4vw0000gn/C/ export CCHROOT=/var/folders/q2/nn87n125621g5t3h_n_nx4vw0000gn/C/ export CHMOD=/bin/chmod export CHOWN=/usr/sbin/chown export CLANG_ANALYZER_NONNULL=YES export CLANG_CXX_LANGUAGE_STANDARD=gnu++0x export CLANG_CXX_LIBRARY=libc++ export CLANG_ENABLE_MODULES=YES export CLANG_ENABLE_MODULE_DEBUGGING=NO export CLANG_ENABLE_OBJC_ARC=YES export CLANG_MODULES_BUILD_SESSION_FILE=/Users/<user>/Library/Developer/Xcode/DerivedData/ModuleCache/Session.modulevalidation export CLANG_WARN_BOOL_CONVERSION=YES export CLANG_WARN_CONSTANT_CONVERSION=YES export CLANG_WARN_DIRECT_OBJC_ISA_USAGE=YES_ERROR export CLANG_WARN_DOCUMENTATION_COMMENTS=YES export CLANG_WARN_EMPTY_BODY=YES export CLANG_WARN_ENUM_CONVERSION=YES export CLANG_WARN_INFINITE_RECURSION=YES export CLANG_WARN_INT_CONVERSION=YES export CLANG_WARN_OBJC_ROOT_CLASS=YES_ERROR export CLANG_WARN_SUSPICIOUS_MOVE=YES export CLANG_WARN_SUSPICIOUS_MOVES=YES export CLANG_WARN_UNREACHABLE_CODE=YES export CLANG_WARN__DUPLICATE_METHOD_MATCH=YES export CLASS_FILE_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export CLEAN_PRECOMPS=YES export CLONE_HEADERS=NO export CODESIGNING_FOLDER_PATH=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products/Release-iphoneos/libdouble-conversion.a export CODE_SIGNING_ALLOWED=NO export CODE_SIGNING_REQUIRED=YES export CODE_SIGN_CONTEXT_CLASS=XCiPhoneOSCodeSignContext export CODE_SIGN_IDENTITY=“iPhone Developer” export COLOR_DIAGNOSTICS=NO export COMBINE_HIDPI_IMAGES=NO export COMMAND_MODE=legacy export COMPOSITE_SDK_DIRS=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/CompositeSDKs export COMPRESS_PNG_FILES=YES export CONFIGURATION=Release export CONFIGURATION_BUILD_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products/Release-iphoneos export CONFIGURATION_TEMP_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export COPYING_PRESERVES_HFS_DATA=NO export COPY_HEADERS_RUN_UNIFDEF=NO export COPY_PHASE_STRIP=NO export COPY_RESOURCES_FROM_STATIC_FRAMEWORKS=YES export CORRESPONDING_SIMULATOR_PLATFORM_DIR=/Applications/ export CORRESPONDING_SIMULATOR_PLATFORM_NAME=iphonesimulator export CORRESPONDING_SIMULATOR_SDK_DIR=/Applications/ export CORRESPONDING_SIMULATOR_SDK_NAME=iphonesimulator10.3 export CP=/bin/cp export CREATE_INFOPLIST_SECTION_IN_BINARY=NO export CURRENT_ARCH=arm64 export CURRENT_VARIANT=normal export DEAD_CODE_STRIPPING=YES export DEBUGGING_SYMBOLS=YES export DEBUG_INFORMATION_FORMAT=dwarf-with-dsym export export DEFAULT_KEXT_INSTALL_PATH=/System/Library/Extensions export DEFINES_MODULE=NO export DEPLOYMENT_LOCATION=NO export DEPLOYMENT_POSTPROCESSING=NO export DEPLOYMENT_TARGET_CLANG_ENV_NAME=IPHONEOS_DEPLOYMENT_TARGET export DEPLOYMENT_TARGET_CLANG_FLAG_NAME=miphoneos-version-min export DEPLOYMENT_TARGET_CLANG_FLAG_PREFIX=-miphoneos-version-min= export DEPLOYMENT_TARGET_SETTING_NAME=IPHONEOS_DEPLOYMENT_TARGET export DEPLOYMENT_TARGET_SUGGESTED_VALUES=“8.0 8.1 8.2 8.3 8.4 9.0 9.1 9.2 9.3 10.0 10.1 10.2 10.3” export DERIVED_FILES_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export DERIVED_FILE_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export DERIVED_SOURCES_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export DEVELOPER_APPLICATIONS_DIR=/Applications/ export DEVELOPER_BIN_DIR=/Applications/ export DEVELOPER_DIR=/Applications/ export DEVELOPER_FRAMEWORKS_DIR=/Applications/ export DEVELOPER_FRAMEWORKS_DIR_QUOTED=/Applications/ export DEVELOPER_LIBRARY_DIR=/Applications/ export DEVELOPER_SDK_DIR=/Applications/ export DEVELOPER_TOOLS_DIR=/Applications/ export DEVELOPER_USR_DIR=/Applications/ export DEVELOPMENT_LANGUAGE=English export DEVELOPMENT_TEAM=V9WTTPBFK9 export DO_HEADER_SCANNING_IN_JAM=NO export DSTROOT=/tmp/React.dst export DT_TOOLCHAIN_DIR=/Applications/ export DWARF_DSYM_FILE_NAME=libdouble-conversion.a.dSYM export DWARF_DSYM_FILE_SHOULD_ACCOMPANY_PRODUCT=NO export DWARF_DSYM_FOLDER_PATH=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products/Release-iphoneos export EFFECTIVE_PLATFORM_NAME=-iphoneos export EMBEDDED_CONTENT_CONTAINS_SWIFT=NO export EMBEDDED_PROFILE_NAME=embedded.mobileprovision export EMBED_ASSET_PACKS_IN_PRODUCT_BUNDLE=NO export ENABLE_BITCODE=YES export ENABLE_DEFAULT_HEADER_SEARCH_PATHS=YES export ENABLE_HEADER_DEPENDENCIES=YES export ENABLE_NS_ASSERTIONS=NO export ENABLE_ON_DEMAND_RESOURCES=NO export ENABLE_STRICT_OBJC_MSGSEND=YES export ENABLE_TESTABILITY=NO export ENTITLEMENTS_REQUIRED=YES export EXCLUDED_INSTALLSRC_SUBDIRECTORY_PATTERNS=“.DS_Store .svn .git .hg CVS” export EXCLUDED_RECURSIVE_SEARCH_PATH_SUBDIRECTORIES=“*.nib *.lproj *.framework *.gch .xcode .xcassets () .DS_Store CVS .svn .git .hg *.pbproj *.pbxproj” export EXECUTABLE_EXTENSION=a export EXECUTABLE_NAME=libdouble-conversion.a export EXECUTABLE_PATH=libdouble-conversion.a export EXECUTABLE_PREFIX=lib export EXECUTABLE_SUFFIX=.a export EXPANDED_CODE_SIGN_IDENTITY= export EXPANDED_CODE_SIGN_IDENTITY_NAME= export EXPANDED_PROVISIONING_PROFILE= export FILE_LIST=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export FIXED_FILES_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export FRAMEWORK_FLAG_PREFIX=-framework export FRAMEWORK_SEARCH_PATHS=“/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products/Release-iphoneos " export FRAMEWORK_VERSION=A export FULL_PRODUCT_NAME=libdouble-conversion.a export GCC3_VERSION=3.3 export GCC_C_LANGUAGE_STANDARD=gnu99 export GCC_NO_COMMON_BLOCKS=YES export GCC_PFE_FILE_C_DIALECTS=“c objective-c c++ objective-c++” export GCC_THUMB_SUPPORT=YES export GCC_TREAT_WARNINGS_AS_ERRORS=NO export export GCC_VERSION_IDENTIFIER=com_apple_compilers_llvm_clang_1_0 export GCC_WARN_64_TO_32_BIT_CONVERSION=YES export GCC_WARN_ABOUT_MISSING_PROTOTYPES=YES export GCC_WARN_ABOUT_RETURN_TYPE=YES_ERROR export GCC_WARN_INITIALIZER_NOT_FULLY_BRACKETED=YES export GCC_WARN_SHADOW=YES export GCC_WARN_UNDECLARED_SELECTOR=YES export GCC_WARN_UNINITIALIZED_AUTOS=YES_AGGRESSIVE export GCC_WARN_UNUSED_FUNCTION=YES export GCC_WARN_UNUSED_VARIABLE=YES export GENERATE_MASTER_OBJECT_FILE=NO export GENERATE_PKGINFO_FILE=NO export GENERATE_PROFILING_CODE=NO export GENERATE_TEXT_BASED_STUBS=NO export GID=20 export GROUP=staff export HEADERMAP_INCLUDES_FLAT_ENTRIES_FOR_TARGET_BEING_BUILT=YES export HEADERMAP_INCLUDES_FRAMEWORK_ENTRIES_FOR_ALL_PRODUCT_TYPES=YES export HEADERMAP_INCLUDES_NONPUBLIC_NONPRIVATE_HEADERS=YES export HEADERMAP_INCLUDES_PROJECT_HEADERS=YES export HEADERMAP_USES_FRAMEWORK_PREFIX_ENTRIES=YES export HEADERMAP_USES_VFS=NO export HEADER_SEARCH_PATHS=”/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products/Release-iphoneos/include " export HIDE_BITCODE_SYMBOLS=YES export HOME=/Users/<user> export ICONV=/usr/bin/iconv export INFOPLIST_EXPAND_BUILD_SETTINGS=YES export INFOPLIST_OUTPUT_FORMAT=binary export INFOPLIST_PREPROCESS=NO export INLINE_PRIVATE_FRAMEWORKS=NO export INSTALLHDRS_COPY_PHASE=NO export INSTALLHDRS_SCRIPT_PHASE=NO export INSTALL_DIR=/tmp/React.dst/usr/local/lib export INSTALL_GROUP=staff export INSTALL_MODE_FLAG=u+w,go-w,a+rX export INSTALL_OWNER=gary export INSTALL_PATH=/usr/local/lib export INSTALL_ROOT=/tmp/React.dst export IPHONEOS_DEPLOYMENT_TARGET=8.0 export JAVAC_DEFAULT_FLAGS=“-J-Xms64m -J-XX:NewSize=4M -J-Dfile.encoding=UTF8” export JAVA_APP_STUB=/System/Library/Frameworks/JavaVM.framework/Resources/MacOS/JavaApplicationStub export JAVA_ARCHIVE_CLASSES=YES export JAVA_ARCHIVE_TYPE=JAR export JAVA_COMPILER=/usr/bin/javac export JAVA_FRAMEWORK_RESOURCES_DIRS=Resources export JAVA_JAR_FLAGS=cv export JAVA_SOURCE_SUBDIR=. export JAVA_USE_DEPENDENCIES=YES export JAVA_ZIP_FLAGS=-urg export JIKES_DEFAULT_FLAGS=“+E +OLDCSO” export KEEP_PRIVATE_EXTERNS=NO export LD_DEPENDENCY_INFO_FILE=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export LD_GENERATE_MAP_FILE=NO export LD_MAP_FILE_PATH=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export LD_NO_PIE=NO export LD_QUOTE_LINKER_ARGUMENTS_FOR_COMPILER_DRIVER=YES export LEGACY_DEVELOPER_DIR=/Applications/ export LEX=lex export LIBRARY_FLAG_NOSPACE=YES export LIBRARY_FLAG_PREFIX=-l export LIBRARY_KEXT_INSTALL_PATH=/Library/Extensions export LIBRARY_SEARCH_PATHS=“/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products/Release-iphoneos " export LINKER_DISPLAYS_MANGLED_NAMES=NO export LINK_FILE_LIST_normal_arm64=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export LINK_FILE_LIST_normal_armv7=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export LINK_WITH_STANDARD_LIBRARIES=YES export LOCALIZABLE_CONTENT_DIR= export LOCAL_ADMIN_APPS_DIR=/Applications/Utilities export LOCAL_APPS_DIR=/Applications export LOCAL_DEVELOPER_DIR=/Library/Developer export LOCAL_LIBRARY_DIR=/Library export LOCROOT= export LOCSYMROOT= export MACH_O_TYPE=staticlib export MAC_OS_X_PRODUCT_BUILD_VERSION=16F73 export MAC_OS_X_VERSION_ACTUAL=101205 export MAC_OS_X_VERSION_MAJOR=101200 export MAC_OS_X_VERSION_MINOR=1205 export METAL_LIBRARY_FILE_BASE=default export METAL_LIBRARY_OUTPUT_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products/Release-iphoneos/ export MODULE_CACHE_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/ModuleCache export MTL_ENABLE_DEBUG_INFO=NO export NATIVE_ARCH=armv7 export NATIVE_ARCH_32_BIT=i386 export NATIVE_ARCH_64_BIT=x86_64 export NATIVE_ARCH_ACTUAL=x86_64 export NO_COMMON=YES export OBJECT_FILE_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export OBJECT_FILE_DIR_normal=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export OBJROOT=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates export ONLY_ACTIVE_ARCH=NO export OS=MACOS export OSAC=/usr/bin/osacompile export OTHER_LDFLAGS=-ObjC export export PASCAL_STRINGS=YES export PATH=”/Applications/" export PATH_PREFIXES_EXCLUDED_FROM_HEADER_DEPENDENCIES=“/usr/include /usr/local/include /System/Library/Frameworks /System/Library/PrivateFrameworks /Applications/ /Applications/ /Applications/” export PFE_FILE_C_DIALECTS=c++ export PKGINFO_FILE_PATH=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export PLATFORM_DEVELOPER_APPLICATIONS_DIR=/Applications/ export PLATFORM_DEVELOPER_BIN_DIR=/Applications/ export PLATFORM_DEVELOPER_LIBRARY_DIR=/Applications/ export PLATFORM_DEVELOPER_SDK_DIR=/Applications/ export PLATFORM_DEVELOPER_TOOLS_DIR=/Applications/ export PLATFORM_DEVELOPER_USR_DIR=/Applications/ export PLATFORM_DIR=/Applications/ export PLATFORM_DISPLAY_NAME=iOS export PLATFORM_NAME=iphoneos export PLATFORM_PREFERRED_ARCH=arm64 export PLATFORM_PRODUCT_BUILD_VERSION=14E8301 export PLIST_FILE_OUTPUT_FORMAT=binary export PRECOMPS_INCLUDE_HEADERS_FROM_BUILT_PRODUCTS_DIR=YES export PRECOMP_DESTINATION_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export PRESERVE_DEAD_CODE_INITS_AND_TERMS=NO export PRIVATE_HEADERS_FOLDER_PATH=/usr/local/include/double-conversion export PRODUCT_MODULE_NAME=double_conversion export PRODUCT_NAME=double-conversion export PRODUCT_SETTINGS_PATH= export export PROFILING_CODE=NO export PROJECT=React export PROJECT_DERIVED_FILE_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export PROJECT_DIR=/Users/<user>/Documents/code/<project>/node_modules/react-native/React export PROJECT_FILE_PATH=/Users/<user>/Documents/code/<project>/node_modules/react-native/React/React.xcodeproj export PROJECT_NAME=React export PROJECT_TEMP_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export PROJECT_TEMP_ROOT=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates export PUBLIC_HEADERS_FOLDER_PATH=/usr/local/include export RECURSIVE_SEARCH_PATHS_FOLLOW_SYMLINKS=YES export REMOVE_CVS_FROM_RESOURCES=YES export REMOVE_GIT_FROM_RESOURCES=YES export REMOVE_HEADERS_FROM_EMBEDDED_BUNDLES=YES export REMOVE_HG_FROM_RESOURCES=YES export REMOVE_SVN_FROM_RESOURCES=YES export REZ_COLLECTOR_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export REZ_EXECUTABLE=YES export REZ_OBJECTS_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export REZ_SEARCH_PATHS=“/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products/Release-iphoneos " export SCAN_ALL_SOURCE_FILES_FOR_INCLUDES=NO export SCRIPT_INPUT_FILE_COUNT=0 export SCRIPT_OUTPUT_FILE_COUNT=0 export SDKROOT=/Applications/ export SDK_DIR=/Applications/ export SDK_DIR_iphoneos10_3=/Applications/ export SDK_NAME=iphoneos10.3 export SDK_NAMES=iphoneos10.3 export SDK_PRODUCT_BUILD_VERSION=14E8301 export SDK_VERSION=10.3 export SDK_VERSION_ACTUAL=100300 export SDK_VERSION_MAJOR=100000 export SDK_VERSION_MINOR=300 export SED=/usr/bin/sed export SEPARATE_STRIP=YES export SEPARATE_SYMBOL_EDIT=NO export SET_DIR_MODE_OWNER_GROUP=YES export SET_FILE_MODE_OWNER_GROUP=NO export SHALLOW_BUNDLE=NO export SHARED_DERIVED_FILE_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products/Release-iphoneos/DerivedSources export SHARED_PRECOMPS_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/PrecompiledHeaders export SKIP_INSTALL=YES export SOURCE_ROOT=/Users/<user>/Documents/code/<project>/node_modules/react-native/React export SRCROOT=/Users/<user>/Documents/code/<project>/node_modules/react-native/React export STRINGS_FILE_OUTPUT_ENCODING=binary export STRIP_BITCODE_FROM_COPIED_FILES=YES export STRIP_INSTALLED_PRODUCT=YES export STRIP_STYLE=debugging export SUPPORTED_DEVICE_FAMILIES=1,2 export SUPPORTED_PLATFORMS=“iphonesimulator iphoneos” export SUPPORTS_TEXT_BASED_API=NO export SWIFT_PLATFORM_TARGET_PREFIX=ios export SYMROOT=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products export SYSTEM_ADMIN_APPS_DIR=/Applications/Utilities export SYSTEM_APPS_DIR=/Applications export SYSTEM_CORE_SERVICES_DIR=/System/Library/CoreServices export SYSTEM_DEMOS_DIR=/Applications/Extras export SYSTEM_DEVELOPER_APPS_DIR=/Applications/ export SYSTEM_DEVELOPER_BIN_DIR=/Applications/ export SYSTEM_DEVELOPER_DEMOS_DIR=”/Applications/ Examples" export SYSTEM_DEVELOPER_DIR=/Applications/ export SYSTEM_DEVELOPER_DOC_DIR=“/Applications/ Reference Library” export SYSTEM_DEVELOPER_GRAPHICS_TOOLS_DIR=“/Applications/ Tools” export SYSTEM_DEVELOPER_JAVA_TOOLS_DIR=“/Applications/ Tools” export SYSTEM_DEVELOPER_PERFORMANCE_TOOLS_DIR=“/Applications/ Tools” export SYSTEM_DEVELOPER_RELEASENOTES_DIR=“/Applications/ Reference Library/releasenotes” export SYSTEM_DEVELOPER_TOOLS=/Applications/ export SYSTEM_DEVELOPER_TOOLS_DOC_DIR=“/Applications/ Reference Library/documentation/DeveloperTools” export SYSTEM_DEVELOPER_TOOLS_RELEASENOTES_DIR=“/Applications/ Reference Library/releasenotes/DeveloperTools” export SYSTEM_DEVELOPER_USR_DIR=/Applications/ export SYSTEM_DEVELOPER_UTILITIES_DIR=/Applications/ export SYSTEM_DOCUMENTATION_DIR=/Library/Documentation export SYSTEM_KEXT_INSTALL_PATH=/System/Library/Extensions export SYSTEM_LIBRARY_DIR=/System/Library export TAPI_VERIFY_MODE=ErrorsOnly export TARGETED_DEVICE_FAMILY=1 export TARGETNAME=double-conversion export TARGET_BUILD_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Products/Release-iphoneos export TARGET_DEVICE_IDENTIFIER=a91508cf0a769cfc7e6ebb94ce9ced80a913c30b export TARGET_DEVICE_MODEL=iPhone8,1 export TARGET_DEVICE_OS_VERSION=10.3.2 export TARGET_NAME=double-conversion export TARGET_TEMP_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export TEMP_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export TEMP_FILES_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export TEMP_FILE_DIR=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/ export TEMP_ROOT=/Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates export export TOOLCHAIN_DIR=/Applications/ export TREAT_MISSING_BASELINES_AS_TEST_FAILURES=NO export UID=501 export UNSTRIPPED_PRODUCT=NO export USER=gary export USER_APPS_DIR=/Users/<user>/Applications export USER_LIBRARY_DIR=/Users/<user>/Library export USE_DYNAMIC_NO_PIC=YES export USE_HEADERMAP=YES export USE_HEADER_SYMLINKS=NO export VALIDATE_PRODUCT=YES export VALID_ARCHS=“arm64 armv7 armv7s” export VERBOSE_PBXCP=NO export VERSION_INFO_BUILDER=gary export VERSION_INFO_FILE=double-conversion_vers.c export VERSION_INFO_STRING=“"@(#)PROGRAM:double-conversion PROJECT:React-"” export WARNING_CFLAGS=“-Wextra -Wall -Wno-semicolon-before-method-body” export WRAP_ASSET_PACKS_IN_SEPARATE_DIRECTORIES=NO export XCODE_APP_SUPPORT_DIR=/Applications/ export XCODE_PRODUCT_BUILD_VERSION=8E3004b export XCODE_VERSION_ACTUAL=0833 export XCODE_VERSION_MAJOR=0800 export XCODE_VERSION_MINOR=0830 export XPCSERVICES_FOLDER_PATH=/XPCServices export YACC=yacc export arch=arm64 export variant=normal /bin/sh -c /Users/<user>/Library/Developer/Xcode/DerivedData/<project>-coouvzgirqlxsaeaczzuypknpazb/Build/Intermediates/

Unpacking /Users/<user>/.rncache/glog-0.3.4.tar.gz… checking for a BSD-compatible install… /usr/bin/install -c checking whether build environment is sane… yes /Users/<user>/Documents/code/<project>/node_modules/react-native/third-party/glog-0.3.4/missing: Unknown --is-lightweight' option Try /Users/<user>/Documents/code/<project>/node_modules/react-native/third-party/glog-0.3.4/missing --help’ for more information configure: WARNING: ‘missing’ script is too old or missing checking for arm-apple-darwin-strip… no checking for strip… strip checking for a thread-safe mkdir -p… ./install-sh -c -d checking for gawk… no checking for mawk… no checking for nawk… no checking for awk… awk checking whether make sets $(MAKE)… yes checking whether make supports nested variables… yes checking for arm-apple-darwin-gcc… no checking for gcc… gcc checking whether the C compiler works… no configure: error: in /Users/<user>/Documents/code/<project>/node_modules/react-native/third-party/glog-0.3.4': configure: error: C compiler cannot create executables See config.log’ for more details Command /bin/sh failed with exit code 77

You are receiving this because you commented. Reply to this email directly, view it on GitHub, or mute the thread

Building my parent / main project still fails: I multiple of these errors:

Undefined symbols for architecture x86_64:
  "folly::detail::formatBinary", referenced from:

I also noticed that the files linked from the React project are wrong/missing. For example: node_modules/react-native/React/folly-2016.09.26.00/folly/dynamic.cpp node_modules/react-native/React/glog-0.3.4/src/config.h Which doesn’t exist.

If I build a new project using react-native init the same files in the React project have these link: node_modules/react-native/third-party/folly-2016.09.26.00/folly/dynamic.cpp node_modules/react-native/third-party/glog-0.3.4/src/config.h Which do exist.

(btw I’m not using CocoaPods)

I’ve got the same issue. 😦

Yeah, if you could try removing the folder again, and try if running that script still works, that’d be awesome!