iotedge: iotedge check error: config.yaml has correct URIs for daemon mgmt endpoint - Error

Expected Behavior

iotedge check should be passed

Current Behavior

config.yaml has correct URIs for daemon mgmt endpoint - Error

Steps to Reproduce

Provide a detailed set of steps to reproduce the bug. 1.updating iotedge daemon to 1.0.10 2.restart device iotedge check 4.

Context (Environment)

Output of iotedge check

Click here

config.yaml has correct URIs for daemon mgmt endpoint - Error
    Unable to find image '' locally
    1.0.10: Pulling from azureiotedge-diagnostics
    b9e6fec25718: Already exists
    909c0cde5070: Already exists
    c96327c6c17f: Already exists
    bbd8c93a942a: Already exists
    9b87e22bb11a: Already exists
    4d7335a78b54: Already exists
    df7387814126: Pulling fs layer
    c9f46c2fce6c: Pulling fs layer
    076984b59710: Pulling fs layer
    8368ffadb3f2: Pulling fs layer
    076984b59710: Waiting
    8368ffadb3f2: Waiting
    c9f46c2fce6c: Verifying Checksum
    c9f46c2fce6c: Download complete
    df7387814126: Verifying Checksum
    df7387814126: Download complete
    df7387814126: Pull complete
    8368ffadb3f2: Verifying Checksum
    8368ffadb3f2: Download complete
    c9f46c2fce6c: Pull complete
    076984b59710: Verifying Checksum
    076984b59710: Download complete
    076984b59710: Pull complete
    8368ffadb3f2: Pull complete
    Digest: sha256:01d3348865716a28ef84b0ddc2f69e7560d3a6d5425db3740960222f96e381d6
    Status: Downloaded newer image for
    One or more errors occurred. (Only 'http' and 'https' schemes are allowed. (Parameter 'requestUri'))

Device Information

  • Host OS [e.g. Ubuntu 16.04, Ubuntu 18.04, Windows IoT Core]: Windows LTSB 2019
  • Architecture [e.g. amd64, arm32, arm64]: arm64
  • Container OS [e.g. Linux containers, Windows containers]: Windows containers

Runtime Versions

  • iotedged [run iotedge version]: 1.0.10
  • Edge Agent [image tag (e.g. 1.0.0)]: 1.0.10
  • Edge Hub [image tag (e.g. 1.0.0)]: 1.0.10
  • Docker/Moby [run docker version]: 1.40

About this issue

  • Original URL
  • State: closed
  • Created 4 years ago
  • Comments: 21 (8 by maintainers)

Most upvoted comments

When I tried to stop these container, I had error that I have permission denied.

Yes, you were right. I have resolved a solution using docker forum.

For those people who might encounter following error: The issue is regarding docker daemon issue. I have resolved it using solution described here:

A solution: 
1. sudo aa-status
2. sudo systemctl disable apparmor.service --now
3. sudo service apparmor teardown
4. sudo aa-status

After these steps I restarted ```docker``` and ```iotedge``` daemons and restarted my RPI. After restarting I have everything working again. The issue happened when I tried to upgrade to newer version of IoT Edge and perhaps it was due to not fully removing some docker/iotedge stuff. Please be aware when performing such stuff.