angular-cli: Cannot find type definition file for 'chai'.


Ubuntu 16.04


angular-cli: 1.0.0-beta.19-3 node: 6.7.0 os: linux x64

Repro steps.

The log given by the failure.

wunder@Code-VirtualBox:~/projects/angular2-firebase-material-demo$ npm start

> angular2-firebase-material-demo@0.0.0 start /home/wunder/projects/angular2-firebase-material-demo
> ng serve --host

** NG Live Development Server is running on **                                   12923ms building modules                                                               6ms add04101ms2195ms asse117ms emitting
Hash: af987254a406091fbfc8
Version: webpack 2.1.0-beta.25
Time: 20388ms
           Asset     Size  Chunks             Chunk Names
  main.bundle.js  4.71 MB    0, 2  [emitted]  main
styles.bundle.js  28.5 kB    1, 2  [emitted]  styles
       inline.js  5.53 kB       2  [emitted]  inline  5.05 MB    0, 2  [emitted]  main  36.8 kB    1, 2  [emitted]  styles  5.59 kB       2  [emitted]  inline
      index.html  1.42 kB          [emitted]  

ERROR in [default] /home/wunder/projects/angular2-firebase-material-demo/node_modules/rxjs/observable/PairsObservable.d.ts:1:0 
Cannot find type definition file for 'chai'.

ERROR in [default] /home/wunder/projects/angular2-firebase-material-demo/node_modules/rxjs/observable/dom/AjaxObservable.d.ts:1:0 
Cannot find type definition file for 'chai'.
Child html-webpack-plugin for "index.html":
         Asset    Size  Chunks       Chunk Names
    index.html  3.8 kB       0       
webpack: bundle is now VALID.`

About this issue

  • Original URL
  • State: closed
  • Created 8 years ago
  • Reactions: 6
  • Comments: 19 (4 by maintainers)

Commits related to this issue

Most upvoted comments

@tarlepp It seems rxjs requires @types/chai somehow. I also ran into the same error message and I could solve with this in my case. Hope this helps you as a workaround to suppress the error messages.

npm i --save-dev @types/chai

I think chai is a test framework, so hope rxjs should not include the dependency in the released module.

The solution of @tmtk75 worked for me on RxJS RC5