angular-cli: angular-cli installation fails renaming /usr/local/lib/node_modules/.staging/abbrev


Mac on latest El Capitan node v6.2.2 with npm 3.10.2

Repro steps.

  • trying to upgrading to latest cli tools (sudo npm install -g angular-cli or sudo npm update -g angular-cli not sure which i run)
  • angular-cli / npm broken
  • reintalling node
  • trying to install angular-cli again
  • intallation allways fails


$  sudo npm install -g angular-cli
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
└── (empty)

npm ERR! Darwin 15.5.0
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "angular-cli"
npm ERR! node v6.2.2
npm ERR! npm  v3.10.2
npm ERR! path /usr/local/lib/node_modules/.staging/abbrev-432cdd5a
npm ERR! code ENOENT
npm ERR! errno -2
npm ERR! syscall rename

npm ERR! enoent ENOENT: no such file or directory, rename '/usr/local/lib/node_modules/.staging/abbrev-432cdd5a' -> '/usr/local/lib/node_modules/angular-cli/node_modules/ember-cli/node_modules/npm/node_modules/abbrev'
npm ERR! enoent ENOENT: no such file or directory, rename '/usr/local/lib/node_modules/.staging/abbrev-432cdd5a' -> '/usr/local/lib/node_modules/angular-cli/node_modules/ember-cli/node_modules/npm/node_modules/abbrev'
npm ERR! enoent This is most likely not a problem with npm itself
npm ERR! enoent and is related to npm not being able to find a file.
npm ERR! enoent 

npm ERR! Please include the following file with any support request:
npm ERR!     /Users/manuelfink/git/angular-2-cli-test/ContentFlows/npm-debug.log
npm ERR! code 1

About this issue

  • Original URL
  • State: closed
  • Created 8 years ago
  • Reactions: 11
  • Comments: 24 (3 by maintainers)

Most upvoted comments

UPDATE: uninstalling and reinstalling angular-cli should fix the issue:

as mentioned by @nikokosh and @davidrensh below try:

sudo npm uninstall -g angular-cli
sudo npm install -g angular-cli

This worked for me in the latest versions as well.

Original quick fix: reinstalling node

Somehow in earlier angular-cli version it seemed to me angular-cli somehow broke node installation. Manual fix, uninstalling and reinstalling node completely fixed the issue for me. hope i didn’t forget anything:

#### uninstalling globally installed libs
sudo npm uninstall -g angular-cli
#### uninstall other libs
sudo npm uninstall -g

#### uninstalling node
sudo rm -rf /usr/local/{lib/node{,/.npm,_modules},bin,share/man}/{npm*,node*,man1/node*}
rm -rf /Users/[homedir]/.npm

#### reinstall node

#### update npm to latest
sudo npm install -g npm

#### reinstall angular-cli
sudo npm install -g angular-cli

Related to this: the procedure in the “upgrade guide”:

is very off-putting, a negative quality signal. Many, many developers upgrade many NPM packages every day, without throwing away their NPM cache (!!).

To make these instruction confidence-inspiring, there should be:

  • Explanation, even brief, of why this package (unlike countless others) requires throwing away the whole NPM cache for each upgrade.
  • Hopefully a pointer to some known NPM defect that temporarily justifies the instructions.

I had the same problem on El Capitan node 6.2.1 npm 3.9.3.

It was solved by simple uninstall of angular-cli: sudo npm uninstall -g angular-cli

And its immediate reinstalling: sudo npm install -g angular-cli

Without npm reinstalling you can keep your cache and all the dependencies as it was.

The fixes mentioned here work for me too, but they happen again as soon as I try to run npm install or npm update after the fix. Can someone confirm if this happens too?

Solved by (nothing else): npm uninstall -g angular-cli npm install -g angular-cli

Reinstall -g angular-cli doesn’t help me on win 8.1, node 4+, npm 3+. I get the same error. In the same time if I open location of angular-cli, on my pc and start ng new path\to\app from this location it actually creates folder and install dependencies

I can also confirm that after a failed angular-cli install due to this problem, if you uninstall angular-cli via npm and then reinstall angular-cli globally it works (or worked…for me…once).

Window 10 Node 6.x Npm 3.x

In my case, I first changed my node version to 6.6.0 with npm 3.10.3. And then I changed my permissions of the location where node is located using this link : I again got an error similar to this trail and then i finally uninstalled and installed angular-cli using npm, and finally it worked ! 😃