STAR: Segmentation Fault when running STARsolo SmartSeq

Hey Alex,

I’m trying to transition from running STAR individually on Smart-seq2 data to running STARsolo --soloType SmartSeq. Unfortunately, I’m getting a segmentation fault. I would be surprised if the error is due to the genome or the fastq files as I have run them through STAR (not STARsolo) previously. I’m using STAR 2.7.6a installed from bioconda. See below for the output and let me know if you have any questions. The error occurs ~10-15 minutes after “started mapping” is logged.

Sep 23 09:18:26 ..... started STAR run
Sep 23 09:18:27 ..... loading genome
Sep 23 09:18:54 ..... processing annotations GTF
Sep 23 09:19:16 ..... inserting junctions into the genome indices
Sep 23 09:23:23 ..... started mapping
/usr/bin/bash: line 1:  9315 Segmentation fault      STAR --runThreadN 16 --soloType SmartSeq --readFilesManifest data/BC08-manifest.tsv --soloUMIdedup Exact --soloStrand Unstranded --genomeDir 'output/star-index' --outSAMunmapped Within --readFilesCommand zcat --sjdbGTFfile raw/genome/gencode.v34.chr_patch_hapl_scaff_RNAspike.gtf --sjdbOverhang 99

Thanks, Welles

About this issue

  • Original URL
  • State: closed
  • Created 4 years ago
  • Comments: 38 (15 by maintainers)

Commits related to this issue

Most upvoted comments

Hey Alex,

Using the master branch worked for this example! Thanks for your work debugging this error! I’ll run it on a couple more datasets over the next few days/weeks and I’ll let you know if I run into any more issues but I’ll go ahead and close it out now!

Best, Welles

Hi Alex,

Turns out, the quality string length for the barcode read for the problematic read number is incorrect. So that would explain why the alignment is failing.

However, STAR only provides the appropriate error message (“quality string length is not equal to sequence length”) if I use --readMapNumber so that this problematic read is the very last read; otherwise I get a segmentation fault.

Thank you for your help with this, I bet it will run fine once I fix the fastq file.

Best, Jenks

Hey Alex,

Hmmm that’s weird. I am using trimmed reads so perhaps that is the cause. I’ll re-run with the untrimmed reads for that sample and let you know what happens. Thanks again for your support.

Best, Welles