AlexaPiDEPRECATED: Alexa starts, but won't listen to input

I’ve successfully started Alexa, and she might be listening to input, but I don’t think so. On boot, I get a ‘starting Alexa’ in the log, a ‘hello’ greeting and 3 flashes of my green LED. If I then push the button (or jumper the GPIO directly together, or start the RPi with the GPIO jumpered from GPIO18>GND and remove the jumper), my LED turns to amber for almost exactly a second and then flashes red and shuts off. This is regardless of how long I hold the button/jumper. Now I bought the button as an individual part without a spec sheet, and it has 4 poles, but I’ve tried all different combinations of jumping that to the GPIO18>GND with seemingly no effect. I’m not certain the microphone is working, here’s my output of arecord -L:

    Jabra BIZ 2400 USB, USB Audio
    Hardware device with all software conversions

And here’s what I have in my file:

button = 18 #GPIO Pin with button connected
lights = [24, 25] # GPIO Pins with LED's conneted
device = "plughw:USB" # Name of your microphone/soundcard in arecord -L

(I tried plughw:0 and :1 and I get this error:

Traceback (most recent call last):
  File "/root/AlexaPi/", line 156, in <module>
  File "/root/AlexaPi/", line 124, in start
    inp = alsaaudio.PCM(alsaaudio.PCM_CAPTURE, alsaaudio.PCM_NORMAL, device)
alsaaudio.ALSAAudioError: No such file or directory

Thoughts, anyone?

About this issue

  • Original URL
  • State: closed
  • Created 8 years ago
  • Comments: 36 (14 by maintainers)

Most upvoted comments

I use a usb microphone, and the default device = "plughw:1" works just fine for me. What did it do for you?