github-project-automation-plus: Error: Resource not accessible by integration

For some reason I am unable to get this action to work.

My repo is public and not a fork.

I’ve also tested another action which did work but has very limited functionalities, this is why I’d like to use this action.

I also tried to include the new permission system to modify the default permissions. I tried both as job and as workflow variable. (

But generally it doesn’t seem to be a permission issue tho when looking at the log image

The project is called Backlog and the column Triage image

At this point I am clueless and thats why I opened this issue 😐

Also the Actions permissions image

Also using a repository secret did not worked Bad credentials

This is the content of my yml. (it’s the same as the one from your example)

name: Move new issues into Triage

    types: [opened]
    runs-on: ubuntu-latest
      - uses: alex-page/github-project-automation-plus@v0.7.1
          project: Backlog
          column: Triage
          repo-token: ${{ secrets.GITHUB_TOKEN }}

Let me know if there is anything else you need. Many thanks in advance!

About this issue

  • Original URL
  • State: closed
  • Created 3 years ago
  • Comments: 16 (5 by maintainers)

Commits related to this issue

Most upvoted comments

Also still not working here when moving new issues to a workboard.

I also reproduced with public repo and public project.

I solved it by creating and using a token with repo permission.

Related issue

repo is needed also for public user Projects and public repos

I am in bed right now, but I can try it tomorrow.

But I’ve already created two more/different projects and they also did not work. (With the same error)

I created a public repository where I reproduced the issue:


name: new-issue-automation

    types: [opened]
    runs-on: ubuntu-latest
      - uses: alex-page/github-project-automation-plus@v0.8.0
          project: "Board"
          column: "Backlog"
          repo-token: ${{ secrets.GITHUB_TOKEN }}

The workflow failing with this error:

Error: Resource not accessible by integration

Link to broken workflow:

It’s working with a personal access token, but with the GITHUB_TOKEN is not working. Therefore, I contacted the GitHub Support, why it’s working with a personal access token, but not with the GITHUB_TOKEN (even when GITHUB_TOKEN has enough permissions).

I got this response from the GitHub Support:

Hi there,

Thank you for contacting GitHub Support.

I took a look at the workflow and was also able to reproduce it.

It doesn’t look like an issue with GITHUB_TOKEN as I was able to use it on other third-party actions.

This looks like the issue is related to the action itself. The owners of the action could reach out to GitHub to investigate the issue with them.

I’m sorry I can’t be of more help, do let us know if you need any further assistance.


@alex-page, do you have the time to contact the support as the GitHub support mentioned, so we can find out, why personal access token is working, but GITHUB_TOKEN not? My support ticket id is 1253216.

I am new to this action and having the same problem. The GITHUB_TOKEN definitely has permission RepositoryProjects: write. If this action previously worked with GITHUB_TOKEN and recently fails, it might be GitHub’s issue. (somewhat like actions/starter-workflows#332 ?) Should we contact GitHub if it is the case?

Can you share a link to your repo 👀