meross-homeassistant: [MEROSS-API-CHANGED] Integration no longer loads - TypeError: HttpDeviceInfo.__init__()

Describe the bug As of today (upgrading to 2022.12.9) the integration no logers loads with the error below. Tried restarting HA / reloading integration with no luck. Your environment HomeAssistant version: – Home Assistant 2022.12.9 – Hassio Version (if applicable): – Operating System 9.4 – Hardware environment: – Intel i7 (Ubuntu) –

Logs taken when the issue happened

Error occurred. ------------------------------------- Component version: Device info: <Unavailable> Error Message: "An exception occurred while setting up the meross manager. Setup will be retried..."
Traceback (most recent call last):
  File "/config/custom_components/meross_cloud/", line 451, in async_setup_entry
    await meross_coordinator.initial_setup()
  File "/config/custom_components/meross_cloud/", line 149, in initial_setup
    self._client, http_devices, creds_renewed = await get_or_renew_creds(
  File "/config/custom_components/meross_cloud/", line 341, in get_or_renew_creds
    http_devices = await http_client.async_list_devices()
  File "/usr/local/lib/python3.10/site-packages/meross_iot/", line 417, in async_list_devices
    return [HttpDeviceInfo.from_dict(x) for x in result]
  File "/usr/local/lib/python3.10/site-packages/meross_iot/", line 417, in <listcomp>
    return [HttpDeviceInfo.from_dict(x) for x in result]
  File "/usr/local/lib/python3.10/site-packages/meross_iot/model/", line 27, in from_dict
    obj = cls(**new_dict)
TypeError: HttpDeviceInfo.__init__() missing 1 required positional argument: 'skill_number'

About this issue

  • Original URL
  • State: closed
  • Created a year ago
  • Reactions: 9
  • Comments: 22 (3 by maintainers)

Commits related to this issue

Most upvoted comments

Thank you guys. I’ve released the v1.2.7 right away (it’s exactly the same as 1.2.7rc1). We just need now to “spread the voice” to all people who are using this integration around the world.

I’t just too bad Meross changes its API signature keeping the same api version number, which just break existing things. Also, this time we’ve been lucky: I’m currently on hollidays and I had my laptop with me, so I could fix this in a few hours.

Hi all, yeah, Meross API changed. Tracking this issue here

— EDIT — I’m working on that as we speak. I’ve already patched the low-level library. Now I just need to wait for the testing pipeline to run and release the new MerossIot library. Then I need to release a new Meross Integration on HACS. It’ll take a couple of hours in total. As soon as the new version is online, you’ll need to upgrade the integration and restart your HA. I am sorry for the inconvenience, but as you can see, that’s something we don’t control…

Hi all, the beta release that addresses this issue is ready to be tested (the lower-level library has been released right away). I need some volunteers to test it and report back if that solves the issue.

You can enable “beta releasaes” directly from HACS. You’ll find a release named “Prerelease v1.2.7rc1”: that is the one to be tested. Update your HA component, restart HA and please report back if that’s working again. As soon as I get some confirmation, I’ll proceed with producing the stable v1.2.7 release.

Hi ! I think it’s my first comment on GitHub, but I really need to say THANK YOU !!! I’m using your Meross integration with some automations in my house, and you resolved this issue so fast ! BRAVO @albertogeniola and all people who worked on it

Thank you so much for incredible speed of response.

Like what was previously stated, thank you so much for the quick response to address this issue. Your work is greatly appreciated.

I reloaded the integration an that did not work, I think the API address is down,

I’m presuming it is not down as the Meross app can control the devices from the cloud