alexa_media_player: Unable to configure w/ v2.0.x, getting stuck at the "Begin" configurator and unable to login

Describe the bug Configurator fails to advance to the next step and allow a login in 2.x.x. Clicking on Confirm in the Begin step on the configurator just cycles repeatedly. The workaround is to login through 1.4.1 and then upgrade again. —Old text As the title says, I was able to resolve this myself but thought it was important to report. After upgrading from 1.41 to 2.0.0, I got the familiar notification to start the configuration flow. But when I pressed the “Confirm” button, it created a SECOND notification, then cleared the dialog. But the original notification remained. Subsequent attempts produced the same results.

To Reproduce Steps to reproduce the behavior:

  1. Installed update
  2. Click on configuration message in notifications
  3. Click on Confirm button
  4. A second notification briefly shows, then disappears. Dialog disappears but original configuration notification remains.

Screen capture of sequence above:

Expected behavior Standard update of pickle file and notification clearing.

System details

  • Home-assistant (version): 0.97.2
  • Hassio (Yes/No): Yes
  • alexa_media (version from or HA startup): 2.0.0
  • alexapy (version from pip show alexapy or HA startup): 1.0.0

Additional context No error was shown in the home assistant logs. Tried this with Chrome and FF, cleared cookies and cache. No change. Downgraded to 1.41 and rebooted. Configuration flow worked correctly and pickle was updated. Then upgraded to 2.0.0 and rebooted again. Everything is working fine, no additional notifications and Alexa Media Player loaded fine.

If this was just some temporary aberration, feel free to close it but I thought I would document it in case it was important or someone else had the same issue.

About this issue

  • Original URL
  • State: closed
  • Created 5 years ago
  • Reactions: 2
  • Comments: 18 (7 by maintainers)

Most upvoted comments

For the adventurous, alexapy fix staged.

@rpitera thanks for reporting. Btw love your UI.

@sephrioth can you provide some logs for alexapy and alexa_media so we can see what the cause is?