alacritty: Exits immediately if running interactively

alacritty 0.2.1 (compiled from source from OS: Debian Stretch running on ChromeOS via the Linux VM beta. Wayland rather than X11.

Running alacritty -e sleep 5 successfully opens the terminal, waits for 5 seconds and then exits.

alacritty --print-events -e fish or alacritty --print-events -e bash exists immediately, printing this to the console:

$ alacritty --print-events -e fish
glutin event: WindowEvent { window_id: WindowId(Wayland(WindowId(133433686906352))), event: Refresh }

Once it printed this, though I’ve been unable to reproduce it.

$ alacritty -e fish --print-events
Event loop exitting due to error: Input/output error (os error 5) [src/]

For all of these commands alacritty exits 0.

About this issue

  • Original URL
  • State: closed
  • Created 6 years ago
  • Comments: 29 (14 by maintainers)

Most upvoted comments

I’m afraid I no longer have that computer to test

@XiaowenHu96 Your issue is different, it seems like we’re exiting ourselves there is no error present in your logs. Make sure your shell is set to something reasonable, you should test with alacritty -e /bin/bash.

@lpil Just checking, have you tried env WAYLAND_DISPLAY= alacritty? Adding that resolved this issue for me.

@lpil Thanks for the feedback. This is a hard nut to crack since there’s no way to reproduce this, but if I had to make a guess I’d say it might have something to do with the system setup and VM.

I’ll try to write a little patch against master to provide some more debug information when I’ve found the time to do so. Hopefully that will help troubleshooting.

Yes, I have tried these (and also sh) with the same result.

Other terminals such as gnome-terminal, xterm, uxterm, and the ChromeOS terminal work OK.