alacritty: Alacritty Doesn't Open on MacOS Big Sur

MacOS: 11.0 Beta (20A4299v) Alacritty Version: fresh 0.4.3 from the Releases page.


Clicking on the application icon and launching from Spotlight does nothing.

open -a Alacritty: LSOpenURLsWithRole() failed for the application /Applications/ with error -1.

I am able to Show Package Contents and launch the binary directly, so creating a dock shortcut works for now. Most of my other apps work so I wonder if there’s something that needs to be updated here?

This is a very low priority issue since this is such an early beta but I’m just creating it to track the progress. Thanks!

Similar to #943

About this issue

  • Original URL
  • State: closed
  • Created 4 years ago
  • Reactions: 7
  • Comments: 30 (7 by maintainers)

Most upvoted comments

@mauricioklein I install Alacritty through Homebrew brew install --cask alacritty --no-quarantine, but here are two options that might help you:

  1. sudo codesign -f -s - "/Applications/" (ad-hoc signs the executable with your user, -f = force-replaces any bad signature, -s - = ad-hoc signs)


  1. xattr -d /Applications/ (tells macOS not to warn you about lack of signature, etc.)
  1. Alacritty was authorized to run with System Preferences > Security & Privacy > General > Open Anyways
  2. The folder structure of Alacritty (Contents/MacOS/executable_name) is the same as other apps (Amphetimene, AnyLogic, PikoPixel) that open properly.
  3. The app was a clean install when I first created the issue. (I had 0.4.2 before but that was also broken, with a different error.)
  4. touch info.plist does not change the error message from open -a Alacritty or the behavior when double-clicked from Finder.

Thanks for your help!

interesting, did you upgrade your command line tools also? I had to do it manually to fix brew

for whatever reason, most things on Big Sur report the version as 10.16 (e.g sw_vers -productVersion), changing MACOSX_DEPLOYMENT_TARGET to 10.16 and building made it work for me.

- MACOSX_DEPLOYMENT_TARGET="10.11" cargo build --release
+ MACOSX_DEPLOYMENT_TARGET="10.16" cargo build --release
make binary
make app
open ./target/release/osx/

I’ve the same issue on Big Sur 11.3.1 This sudo xattr -r -d ./target/release/osx/ solved an issue.

@mcansh ahh. yes, it works after I fixed brew by sudo xcode-select --switch /Applications/ 👍

Thanks @mcansh , I usually build by make clean app, I missed the binary! Will try later, cheers

Thanks for finding that out. In general, I’d like to wait for apple to release their new macOS, so we can update MACOSX_DEPLOYMENT_TARGET to a proper version based off the system we’re compiling to. I feel like it’s a bit related to their new ARM support to some point, so that’s why different deployment target should be used?

Thanks @4cm4k1 !

I had Alacritty installed via Homebrew before and was having the same problem as now.

None of the commands above worked, unfortunately 😕

I’m, however, getting a different error now:

[executable<alacritty(504)>:95827] Death sentinel fired!

@imjma Sorry for the offtopic, but how did you center your tmux windows list? Screenshot 2020-11-13 at 11 42 58

you can check my conf of tmux

Since macOS 11 is still so fresh, the best bet is probably to give it some time and see if that helps with things. Hopefully they’ll figure it out.