ngx-admin: npm start throw Data path ".builders['app-shell']" should have required property 'class'

Issue description

Current behavior: Not able to start the project.

Expected behavior: Project started

Steps to reproduce: npm start

Other information:

npm, node, OS, Browser

Schema validation failed with the following errors:
  Data path ".builders['app-shell']" should have required property 'class'.
Error: Schema validation failed with the following errors:
  Data path ".builders['app-shell']" should have required property 'class'.
Node, npm: `v10.15.0` and `6.9.0`
OS: macOS (Mojave)

About this issue

  • Original URL
  • State: closed
  • Created 5 years ago
  • Comments: 22

Most upvoted comments

Hey maybe you can try this fix, hope this helps 😃 this link

Changing from “@angular-devkit/build-angular”: “^0.802.1” to “@angular-devkit/build-angular”: “^0.13.9”,

solved my problem, thank you

Hey @bretonio, I’ve deleted the package-lock.json and then I ran npm install. After that, everything looks fine, probably in my case It was update conflict I hope it helps you

Changing from “@angular-devkit/build-angular”: “^0.802.1” to “@angular-devkit/build-angular”: “^0.13.9”, . . . The application works fine for me but a potential security vulnerability warning is found with high priority.

This worked for me:

  1. Opened package.json
  2. Changed “@angular-devkit/build-angular”: “^0.800.0” to
    “@angular-devkit/build-angular”: “^0.10.0”
  3. Run npm install
  4. Run ng serve

Exact same problem when trying to start an Angular project using npm start. My specs:

Node v10.15.1 NPM v6.7.0 Windows 10

Changing from “@angular-devkit/build-angular”: “^0.802.1” to “@angular-devkit/build-angular”: “^0.13.9”, . . . The application works fine for me but a potential security vulnerability warning is found with high priority.

This was also my issue, I ran npm audit and found the vulnerability. I ran npm audit fix and then my app would not run because It reverted to “^0.803.6”.

EDIT: Setting it to “^0.13.9” solved the vulnerability issue ! 😃