goneovim: v0.4.8 crashes on Windows with en_GB locale

UI is briefly visible, but quickly crashes with the following in debug.log:

[1019/124842.015:ERROR:icu_util.cc(177)] Invalid file descriptor to ICU data received.

About this issue

  • Original URL
  • State: closed
  • Created 4 years ago
  • Comments: 15 (7 by maintainers)

Most upvoted comments

Got it working! image

Apparently I’ve had an old empty nvim folder with “bin” in path. Not sure why/how, but maybe Gonevim was using the 1st match and not checking the others? Removing it solved the issue.

I’m glad the problem is solved. Close this issue 😃

Ah, that reminds me, earlier versions of goneovim were bundled with nvim. Oh, yeah.

Your Windows OS Build version.

Relevant info:

OS Version:                10.0.19041 N/A Build 19041
Input Locale:              en-us;English (United States)
Input Locale:              en-us;English (United States)
Time Zone:                 (UTC+09:30) Adelaide
Total Physical Memory:     32,701 MB
Available Physical Memory: 20,212 MB
Hotfix(s):                 6 Hotfix(s) Installed.
                           [01]: KB4578968
                           [02]: KB4561600
                           [03]: KB4570334
                           [04]: KB4577266
                           [05]: KB4580325
                           [06]: KB4579311

Please let me know if something important is missing.

Is nvim.exe in one of the directories listed in the %PATH% environment variable?

I have added Gonevim path to the $PATH (no pun intended) and can launch it from a new PS session: image

Are you sure that this problem occurs in en_GB and not in other locales?

Not anymore, I have changed the system locale to en_US and it still can be reproduced.

Does right-clicking goneovim.exe and running it as an administrator change the behavior of the problem?


If you have virus scanning software running in your environment, does specifying goneovim.exe in the exception list for its real-time detection feature change its behavior?

I do have “Windows Defender” enabled and I don’t see it reacting to Gonevim.

Does any other release besides 0.4.8 have the same problem?

I have tried v0.4.8.1 and it makes a small difference: now blank window does not disappear automatically. See the screenshot above.

Version 0.3.4 works just fine: image

do you have other Qt applications installed that goneovim may not be able to unintentionally reference shared libraries of other Qt applications?

I do have have a few. To eliminate this possibility, I have created a new VM and tried the latest release there, same result: