aiobotocore: Incompatible with botocore >= 1.21.0

Due to dependencies, it is impossible to install aiobotocore together with any other package depending on a recent version of botocore. For example:

aiobotocore==1.4.2 depends on botocore < 1.20.107
boto3==1.18.0 depends on botocore>=1.21.0

Which also makes it impossible to install packages with a dependency on boto3>=1.18.0

About this issue

  • Original URL
  • State: closed
  • Created 3 years ago
  • Comments: 15

Most upvoted comments

@thehesiod Yes, I guess given the tight integration, a new aiobotocore release targeting newer botocore versions would be the only way to “fix” the issues…

I think what you’re saying is you’d like a version bump