autoprefixer-rails: 9.0 Triggering ActionView::Template Error

Rails 5.2 autoprefixer 9.0

All my Rails Capybara tests that try to run with a JavaScript driver give me this:

Failure/Error: = stylesheet_link_tag "application", media: "screen" unless params[:print]

        Current ExecJS runtime does't support ES6. Please install latest Node.js.

      # /Users/noel/.gem/ruby/2.5.1/gems/autoprefixer-rails-9.0.0/lib/autoprefixer-rails/processor.rb:149:in `runtime'

My system is running the latest node and the latest Sprockets beta, as far as I can tell, so I’m not sure exactly what to upgrade.

About this issue

  • Original URL
  • State: closed
  • Created 6 years ago
  • Reactions: 1
  • Comments: 22 (16 by maintainers)

Commits related to this issue

Most upvoted comments

Replace therubyracer by mini_racer in Gemfile:

# gem 'therubyracer', platforms: :ruby
gem 'mini_racer', platforms: :ruby

And then:

$ bundle install

Rails 5.1.6 autoprefixer 9.0 I have same error after modifying sass styles reverting to 8.6.5 solved the issue

@DrobyshevAlex if you can’t use mini_racer you should use Node.js as runtime for ExecJS. Sorry, TheRubyRacer just can’t run Autoprefixer JS.