WPGulp: Error installing, command failed

Bug Report

I get an error when I try and install it The error is

throw err;
Error: Command failed: npm install --silent

I am using the latest versions of node and npm. I am on a Mac OS

About this issue

  • Original URL
  • State: closed
  • Created 6 years ago
  • Comments: 34 (14 by maintainers)

Most upvoted comments

I think this is solved if you change the reference to gulp in package.json. It solved it for me anyhow. It does involve running npm install after npx wpgulp fails.

See issue #128 and the fix in #129

Sorry, folks! I have been super busy. Looks like the latest npm had issues with gulp and now the recommended way to use gulp 4.0 is to write just that. Thanks @tarfoot for the PR #129 this should now be fixed.

Yes the regular npx wpgulp did work.

Eric Greenfield

On September 14, 2018 at 3:13:58 PM, Ahmad Awais ⚡️ (notifications@github.com(mailto:notifications@github.com)) wrote:

For sure it was an issue of your npm’s permissions inside the node-modules. Can you now try the regular one i.e. npx wpgulp and report back before we close this. I’ll add it to FAQs.

— You are receiving this because you were assigned. Reply to this email directly, view it on GitHub(https://github.com/ahmadawais/WPGulp/issues/112#issuecomment-421457463), or mute the thread(https://github.com/notifications/unsubscribe-auth/ALE88hHXi7mig_YD7d7PIX1AE8njNb9Bks5ua__2gaJpZM4Wn4nn).

I deleted the node_modules folder and everything and started over and now it works… im confused… Maybe updating gulp helped? But you said it didn’t need to be installed globally. I dunno…

Now I will test it on the other computer where it was working before!