AFLplusplus: Build failure due to unicornafl.

I am on the ‘stable’ branch, working with commit 1d4f1e48797c064ee71441ba555b29fc3f467983. I am trying to build from source, following the directions for make distrib. The build always fails with the error:

[-] Error: Unicorn mode doesn't seem to work!
make: [GNUmakefile:627: distrib] Error 1 (ignored)

To Reproduce

I have tried two different methods of obtaining the code. In the first method, I did git clone, and then ran make distrib. In the second method, I did git clone --recurse-submodules In both cases, the results were exactly the same; the error above.

Expected behavior

I expected a complete build.

Additional context

lsb_release -a:
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.4 LTS
Release:	20.04
Codename:	focal

uname -a:
Linux Hammer 5.13.0-35-generic #40~20.04.1-Ubuntu SMP Mon Mar 7 09:18:32 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Build Logs

The build logs are too long to put into this issue, but apparently the gist is OK.

About this issue

  • Original URL
  • State: closed
  • Created 2 years ago
  • Comments: 27 (15 by maintainers)

Most upvoted comments

I’m moving to a new apartment these days and I will have a look as soon as possible (once I get everything done and get my desk from IKEA).

Sorry for the delay.

@jamestiotio Cannot reproduce it on Ubuntu 20.04 and same cmake version with a fresh clone of stable branch. Maybe you can try to apt install build-essential?

Sorry for the late reply.

Regarding my issue, I was still unable to get it to install properly without the error, even after following the build steps specified in the Ubuntu 20.04 version of the Dockerfile (from commit 927cb770f0c8c1b0ce576bf6750b33fbb648c598).

Since it is not reproducible on a fresh Ubuntu 20.04 install, I suspect that it is just my local dependencies that are messing things up. I settled with the Docker image instead. Nevertheless, thanks for the help!

@Licae Had the same issue, it’s due to an old cmake version. Upgrading cmake works for me I’ve solved it.Thank you for your advice.

sudo apt remove cmake
sudo snap install cmake --classic

The cmake version was upgraded from V3.10 to V3.22.