selenoid: Failed container creation

docker --version
Docker version 17.03.1-ce, build c6d412e
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.1 LTS
Release:        16.04
Codename:       xenial
sudo docker run --rm -v /var/run/docker.sock:/var/run/docker.sock -v /root:${HOME} aerokube/cm:latest-release selenoid start --vnc --tmpfs 128
2017/07/01 01:28:39 Using Docker...
2017/07/01 01:28:39 url=
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x1 pc=0x7e2353]

goroutine 1 [running]:
        /home/travis/gopath/src/ +0x43, 0xc4201b1cb0, 0x0, 0x3)
        /home/travis/gopath/src/ +0x2c*Command).execute(0xb672e0, 0xc4201b1c20, 0x3, 0x3, 0xb672e0, 0xc4201b1c20)
        /home/travis/gopath/src/ +0x231*Command).ExecuteC(0xb66840, 0xb67720, 0xc42017df68, 0x7e304c)
        /home/travis/gopath/src/ +0x339
        /home/travis/gopath/src/ +0x2d
        /home/travis/gopath/src/ +0x20
{"errors":[{"code":"UNAUTHORIZED","message":"authentication required","detail":null}]}
  "url": "",
  "assets_url": "",
  "upload_url": "{?name,label}",
  "html_url": "",
  "id": 6746048,
  "tag_name": "1.3.2",

About this issue

  • Original URL
  • State: closed
  • Created 7 years ago
  • Comments: 32 (20 by maintainers)

Most upvoted comments

@vania-pooh yes, i tried again with latest versions. Now it’s work fine

My actions:

  1. Set proxy via systemd:
  2. Start Selenoid via cm:
./cm selenoid cleanup && ./cm selenoid configure --vnc --browsers "firefox;chrome;opera" --last-versions 5 --tmpfs 128 && ./cm selenoid start --port 4444 --args "-limit 5 -service-startup-timeout 90s -session-attempt-timeout 90s -session-delete-timeout 90s -timeout 120s"
  1. Start selenoid-ui via docker (not cm), when using cm --> selenoid-ui still not up connection with selenoid
DOCKER_GATEWAY_ADDR=`docker inspect selenoid -f {{.NetworkSettings.Gateway}}`
docker run -d --name selenoid-ui -p 8080:8080 aerokube/selenoid-ui --selenoid-uri http://${DOCKER_GATEWAY_ADDR}:4444
  1. Set selenium proxy capabilities

@KathiresanRamkumar95 try to run this:

$ sudo ./cm selenoid start --force --vnc --browsers "chrome"

@KathiresanRamkumar95 you have no Docker installed or CM tool does not see it. This is why you get latest as versions. Need to make sure that Docker is installed.

@KathiresanRamkumar95 - if you have problems with browsers downloading and you used command from my previous post, then: Selenoid have changes in -- browsers switch (comma separator not supported), i had update my post. please try this:

./cm selenoid cleanup && ./cm selenoid configure --vnc --browsers "firefox;chrome;opera" --last-versions 5 --tmpfs 128 && ./cm selenoid start --port 4444 --args "-limit 5 -service-startup-timeout 90s -session-attempt-timeout 90s -session-delete-timeout 90s -timeout 120s"

@KathiresanRamkumar95 just do docker pull only for selenoid/chrome:XXX images.

@KathiresanRamkumar95 video-recorder is always downloaded, no way to disable this in CM. To download only Chrome type:

$ ./cm selenoid start --browsers chrome --last-versions 5

Selenoid-ui is not able to provide any browsers list[browser selection keep on loading] ,how can i resolve the issue? selenoid